Results 1 to 5 of 5

Thread: engine wont rev past 4k at any gears ???

  1. #1
    n00b
    Join Date
    Apr 2012
    Posts
    4
    Country
    Saudi Arabia

    Question engine wont rev past 4k at any gears ???

    Big hello from saudi arabia


    i am new to forum because i am new atom owner
    .

    i got it used , and it was running fine for couple a days but when i took it out today i found out that it wont rev over 4k at any given gears


    i know the rev limiter is limited at 4k when the car is in neutral and if i hit the pedal it will rev to 4k only , but today it limited the rev on 4k when i am driving


    any idea what could cause the problem ? it did rain the day before and the car wan not fully coverd could it be the problem ?

    (what i mean by revving is engine fuel cut of for safty like when u over rev it it will cut of fuel
    )

  2. #2
    Did you make sure the car had warmed to operating temperature first?
    Quote Originally Posted by aldo View Post
    Big hello from saudi arabia
    i am new to forum because i am new atom owner
    . i got it used , and it was running fine for couple a days but when i took it out today i found out that it wont rev over 4k at any given gears
    i know the rev limiter is limited at 4k when the car is in neutral and if i hit the pedal it will rev to 4k only , but today it limited the rev on 4k when i am driving
    any idea what could cause the problem ? it did rain the day before and the car wan not fully coverd could it be the problem ? (what i mean by revving is engine fuel cut of for safty like when u over rev it it will cut of fuel )

  3. #3
    n00b
    Join Date
    Apr 2012
    Posts
    4
    Country
    Saudi Arabia
    Quote Originally Posted by beckertb View Post
    Did you make sure the car had warmed to operating temperature first?
    OK what is the regular operating temp ? i drove it when its like 70c and still did the same but after a while i turned it off then on again and it was properly warmed and its rev just fine ?

    so is there is a rev limiter when its cold ??? is that correct ?

  4. #4
    Neutron
    Join Date
    Aug 2010
    Posts
    2,677
    Country
    United States
    Im assuming you have the honda engine. Sounds like the 4000rpm is the limp mode and lots of things can do it. I'd recommend calling up the factory since I dont think you have an OBD2 port to see what codes it is running.

    Looking through these threads I see everything from low oil pressure (check your oil), to electrical issues, sensor problems like the MAP failing and other things.

    http://honda-tech.com/tags.php?tag=4000

  5. #5
    n00b
    Join Date
    Apr 2012
    Posts
    4
    Country
    Saudi Arabia
    Quote Originally Posted by bolus View Post
    Im assuming you have the honda engine. Sounds like the 4000rpm is the limp mode and lots of things can do it. I'd recommend calling up the factory since I dont think you have an OBD2 port to see what codes it is running.

    Looking through these threads I see everything from low oil pressure (check your oil), to electrical issues, sensor problems like the MAP failing and other things.

    http://honda-tech.com/tags.php?tag=4000
    thank you beckertb , the link you posted is useful i can see this is a common issue with the atom honda engine .

    got to check the wiring and stuff before i call the factory i doubght they will have a solotion for me just over the phone i will try to minimize the search before i rang them .

    i keep you guys posted about the issue if it fixed .

Similar Threads

  1. Engine Light Question
    By Cyberbug in forum General Ariel Atom Technical Discussion (for all UK and US versions)
    Replies: 8
    Last Post: December 12, 2012, 02:55 PM
  2. I just sold an old engine I had
    By Norm in forum Humor and Off-Topic Discussion
    Replies: 1
    Last Post: April 13, 2012, 01:04 PM
  3. Spaz, is your engine glowing?
    By bolus in forum Photo and Video Galleries
    Replies: 0
    Last Post: January 15, 2012, 09:24 PM
  4. Replacement engine for the Ecotec LSJ?
    By FrankRizzo in forum GM Ecotec LSJ Engine Technical Discussion
    Replies: 2
    Last Post: October 6, 2011, 08:46 AM
  5. Next up - copy-and-past and image preview
    By Terry Kennedy in forum Forum Feedback
    Replies: 4
    Last Post: April 25, 2011, 03:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •