Results 1 to 3 of 3

Thread: PDFs are still not being served properly

  1. #1
    Proton Terry Kennedy's Avatar
    Join Date
    Aug 2010
    Location
    NYC
    Posts
    794
    Country
    United States

    PDFs are still not being served properly

    If I click on a PDF attachment here, I get the Open/Save/Cancel dialog box.

    For example, this attachment:

    CAR36I01.29_181_1.pdf

    Is the same as this link:

    PDF

    But mine opens in the browser and the one from here prompts with open/save/cancel.

  2. #2
    I'm not sure this one can be fixed... vBulletin doesn't link directly to the attachments in a location below the web root (they're actually not on the filesystem anywhere - they're in the database).

    The attachment.php file delivers the file and then is supposed to set the HTTP headers based on the MIME type I put enter in the attachment manager interface, which looks like this:

    ScreenHunter_01 Apr. 28 14.46.jpg

    I've tried Googling for some other options, but am coming up empty. If you can find something I'm missing, I'll give it a shot!

  3. #3
    To confirm the server is doing it right, I manually (and temporarily) uploaded a PDF to the main forums directory. Confirm the headers here:

    http://redbot.org/?uri=http://ariela...rums/alcon.pdf

    Or just download the file here:

    http://arielatomchat.com/forums/alcon.pdf

    You can verify that the HTTP server is delivering the PDF file with the same Content-type header as yours:

    http://redbot.org/?uri=http://www.tm...1.29_181_1.pdf

    Again, not sure how else to convince vBulletin to deliver an attachment properly. I'm open to suggestions!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •