Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Hello from David at TMI AutoTech!

  1. #11
    Particle
    Join Date
    Oct 2011
    Location
    DE
    Posts
    30
    Country
    United States
    Richard, sorry to hear you have had problems, if it helps at all I have not heard any negatives from the guys running the wilwoods in the VIR SRA series. It sounds like you had a bad master. I would make sure you bleed them on a regular basis. The fronts should be easy (too easy with cold tires) to lock up. Most drivers run alot of front bias. -John

  2. #12
    Neutrino MadMaxAtom's Avatar
    Join Date
    Apr 2011
    Location
    Usually in my shop..
    Posts
    1,583
    Country
    United States
    "That kind of negates the point of you being on a public forum full of Atom owners and enthusiasts. Why not share what you can with everyone?'

    Seconded!

    "Most drivers run alot of front bias"....."the fronts should be easy to lock up"

    I run maximum rear brake bias..(including pad compound selection) and the car is MUCH easier to slow under most braking situations, with no fear of skidding the front tires.

    Car turns in much better for me..which lowers my lap times.. (However,I don't run the same tires or sizes as the SRAs)
    Last edited by MadMaxAtom; November 19, 2014 at 07:04 PM.
    The power of an Atom is a terrible thing to waste! Atom owner/operator since 2007. The more you chase perfection,the faster it becomes. John Force for President! (I asked him once in person...he laughed)

  3. #13
    Neutron
    Join Date
    Aug 2010
    Posts
    2,677
    Country
    United States
    David, thanks for the call today. Nice that you are checking in on us old timers to see if we need anything.

    My only recommendation on the Atom 3s would be to get the exhaust a little more shiny

    the high profile toy thrower

  4. #14
    Electron
    Join Date
    Feb 2012
    Location
    Venice, CA
    Posts
    152
    Country
    United States
    David - do you know why the current SRAs ship with 400 Front and 300 Rear Springs? If I recall correctly the 2012 SRA had 400/500 (which is significantly different no?) I swapped them out to 300/400 because 400/500 was far too harsh for the bumpy SoCal tracks. I'm curious then why you guys find the 400/300 setup is the preferred factory setting now compared to 400/500 previously? I'm also then wondering if my brake issues are at all compromised by a 300/400 setup vs a 400/300 setup?

Page 2 of 2 FirstFirst 12

Similar Threads

  1. TMI AutoTech - tour photos
    By Lane in forum Photo and Video Galleries
    Replies: 0
    Last Post: July 5, 2014, 10:42 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •