Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
Like Tree1Likes

Thread: Water temp (AA3 - K24Z7)

  1. #11
    Lepton AtomJohnny's Avatar
    Join Date
    Apr 2011
    Location
    Auckland
    Posts
    284
    Country
    New Zealand
    Quote Originally Posted by silver View Post
    wonder if you have air in your system preventing it from working properly
    That has been a problem in the past with one or two cars. I even experienced it with mine at one stage. Bled the system at the small tap in the top of the radiator. Now runs at 190 mostly. Worst is sitting just after a long hard run (e.g. at lights after just coming off the motorway) where it can reach 205. My fan has a manual override switch that is a good idea.
    01100001 01110100 01101111 01101101 00110001

  2. #12
    Electron
    Join Date
    Aug 2012
    Posts
    153
    Country
    United States
    Now that it's getting warmer in San Diego, my temp has been hitting 195-200 more than I would like. I've looked for a 160 thermostat, but the only aftermarket one I've found was a Mishimoto 140. I don't want to go that low. Does anybody know where I can get a 160 that will fit the k24? Also, does anybody know what temp the 2012 civic si runs at?

  3. #13
    Fermion
    Join Date
    Apr 2012
    Posts
    54
    Quote Originally Posted by AtomJohnny View Post
    That has been a problem in the past with one or two cars. I even experienced it with mine at one stage. Bled the system at the small tap in the top of the radiator. Now runs at 190 mostly. Worst is sitting just after a long hard run (e.g. at lights after just coming off the motorway) where it can reach 205. My fan has a manual override switch that is a good idea.
    Had a tiny hole in the coolant pipe that required the whole system to be drained and refilled to replace it. So unless I had an air in my system and then after a complete refresh of the system still have air in it I would suspect 200 is normal.

  4. #14
    Fermion
    Join Date
    Apr 2012
    Posts
    54
    I can now report that at 225F the "WT" flashes. I was at around 9,000ft and climbing and it was about 95F air temp.

    Car didn't skip a beat and easing off for just a few seconds quickly drops it back to ~205F

  5. #15
    Lepton cvjoint's Avatar
    Join Date
    Mar 2017
    Location
    San Francisco
    Posts
    497
    Country
    United States
    I've hit 215* today on the track and I get a warning. The SRA lights up the last two red rev meter lights to show the warning.

    A bit early to show a warning at that low of a temperature. Quite annoying as it interferes with the rev meeter. Maybe 230* would be better.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Oil Change K24Z7
    By rijowysock in forum General Ariel Atom Discussion (for all UK and US versions)
    Replies: 10
    Last Post: January 28, 2013, 12:27 AM
  2. High temp rubberized coating
    By DarthChicken in forum General Ariel Atom Discussion (for all UK and US versions)
    Replies: 8
    Last Post: August 4, 2011, 09:18 AM
  3. Free Horsepower? Removing Mechanical Water Pump - any downsides?
    By Payne in forum General Ariel Atom Discussion (for all UK and US versions)
    Replies: 0
    Last Post: June 18, 2011, 05:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •